eclipse打开报错:Failed to load the JNI shared library

1.启动eclipse出现如下报错: 弹出框显示:Failed to load t…

1.启动eclipse出现如下报错:
弹出框显示:Failed to load the JNI shared library

2.出现原因以及解决办法:
(1)原因1:JDK和eclipse位数不匹配。
错误原因:安装的JDK和eclipse一个版本位数是64位,一个是32位。要根据自己系统位数来选择JDK和eclipse的版本位数,选择统一的版本(两者都为32位,或都为64位。)

查看jdk和eclipse的版本信息的方法:

jdk : 进入cmd,输入java -version命令,出现如下信息。如果显示了64bit就是64位,没有就是32位。

eclipse:可以查看自己下载的安装包,如果显示的是win32-x86_64,那么就是64位的。或者进入安装路径,查看ini配置文件,用记事本打开查看信息,如果显示win32-x86_64,就是64位。如果显示win32.x86,则表示eclipse是32位的。

本文来自网络,不代表软粉网立场,转载请注明出处:https://www.rfff.net/p/3691.html

作者: HUI

发表评论

您的电子邮箱地址不会被公开。

返回顶部